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CINDEX User’s Guide Supplement

Cindex for Windows
Publishers’ Edition 4.0 

INTRODUCTION

This document describes how the Publishers’ Edition of Cindex™ for Windows differs 
from the standard edition. You should read this supplement in conjunction with the 
User’s Guide to Cindex for Windows.

The Publishers’ Edition differs from the standard edition in two principal ways: it pro-
vides additional features for the indexer and it provides some administrative services that 
make Cindex easier to manage in a networked environment.

Overview of Features
The Publishers’ Edition provides some general capabilities that are not available in the 
standard edition.

Printing Labeled 
Records

When printing an index Cindex can identify a labeled record with a bullet in the margin 
to the left of the column.

Formatting When an index is formatted in indented style, you can force particular subheadings to be 
formatted in run-in style.

Tagged Text Documents Markup tags that identify fonts can contain a placeholder that will cause Cindex to emit 
the font name in the tag.

File Placement The Publishers’ Edition provides a user (or the administrator) more control of the place-
ment of files than is available in the standard edition. Users also have an additional 
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option in the File menu through which they can open only index templates and style 
sheets.

File-Sharing Capabilities Subject to the control of an administrator, multiple users can have the same index open 
at one time. The first user has unrestricted read-write access to the index; any subsequent 
user can have read access.

Application 
Programming Interface

The Publishers' Edition provides an application programming interface (API) that 
allows other programs running under Windows to execute certain Cindex commands 
and retrieve data from Cindex while it is running.

Administrative Services

An administrator can configure Cindex to require the user to enter an identifier before 
being allowed access to any documents; this identifier can be checked against a list of 
authorized users.

An administrator with suitable privileges can control where Cindex saves files and looks 
for files, and whether or not other users can change access settings.

The administrator can control whether or not a user can modify indexes or merely exam-
ine them, and can control whether or not multiple users can have concurrent access to a 
single index.

SPECIAL FEATURES

Opening Stationery
The File menu contains an Open Stationery… item through which you can display and 
open only style sheets and index templates. If you have specified a default folder that 
Cindex should use with style sheets and templates (see “File Placement” on page 3) Cin-
dex will display the contents of that folder when it opens the dialog box.
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Printing Labeled Records
Cindex displays labeled records in distinctive colors. Colored text on the screen is often 
not distinctive when rendered by a printer. To make labeled records distinctive when 
they are printed, you can make Cindex print a bullet in the margin immediately to the 
left of the lowest-level heading that originates from a labeled record.

When you choose Print… from the File menu, check Print Bullet Labeled Entry to make 
Cindex print a bullet in the margin beside a labeled record.

Formatting Entries
In an index that will be formatted in indented style, you can arrange that subheadings 
belonging to specified entries will be formatted in run-in style.

If any subheading in a record begins with a semicolon (;) Cindex will run-on that sub-
heading from the heading above when it displays or prints entries in a fully-formatted 
view.

NOTE: If you display or print an index in run-in style, Cindex will not make allowance 
for any subheadings that you have constructed with leading semicolons—it will display 
or print the semicolon in addition to any it would supply during its normal formatting 
of entries.

Tagged Text Export 
When you define a tag to represent the opening or closing of a font, if you include the 
symbol % in the tag, Cindex will emit the name of the font when it writes the tag to the 
file being saved. To use % as a literal character in a font tag, place a \ immediately before 
it.

NOTE: Cindex treats \ as a literal character unless it is followed by a digit or %.

File Placement
Depending on permissions granted by the administrator, you can specify folders that 
Cindex will use by default when it saves or opens certain kinds of documents.
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You can specify:

• The folder Cindex will take you to when you create, open or save an index.
• The folder Cindex will take you to when you open a template or style sheet with the 

Open Stationery command (File menu) or save a style sheet with Save Style Sheet (File 
menu).

• The folder to which Cindex will take you to when you save sets of abbreviations you 
make.

• The folder in which Cindex will keep sets of markup tags.
• The folder in which Cindex will keep personal dictionaries that you use when you 

check spelling.

If no folders have been set for markup tags and user dictionaries, Cindex uses a private 
folder that is unique to each user.

To make or change any of default folder settings, choose Preferences from the Edit menu, 
then click the Folders tab (Figure 1).

FIGURE 1. Folders Preferences
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Each box shows the path to the default folder for files of a particular type. If no path is 
shown no default folder has been specified.

To specify a default folder for a file of a particular type, click Set…. Cindex will display a 
standard file dialog box through which you can choose the folder you want to use.

NOTE: You can set folders only if the administrator has configured Cindex to permit 
it. The Set… button for a particular file type will be dimmed if the administrator does 
not permit changes to default folders.

To clear a path already set, click Clear.

Sharing Indexes
Subject to permissions granted by the administrator, the Publishers’ Edition allows mul-
tiple users to have concurrent access to a single index.

The first user who opens an index has read-write access, and can freely make and modify 
entries. Any subsequent user who opens the index will have read-only access.

When you try to open an index that is already in use, Cindex will warn you of the fact 
and ask if you want to proceed. If you do open the index, Cindex will display [Read Only] 
beside the title to its main window.

NOTE: The administrator can configure Cindex to prevent shared access to files.

Limitations When you have read-only access to an index, Cindex disables all menu commands that 
could modify entries. If the index is concurrently being modified by another indexer 
your view of entries is not guaranteed to be fully up-to-date.

Application Programming Interface

The Application Programming Interface (API) allows another Windows program to 
execute Cindex commands. The API supports a subset of the commands normally avail-
able through Cindex menus. A specification for the interface is available to registered 
users of the Publishers’ Edition.
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ADMINISTRATION

Cindex Administration
When Cindex is first installed it allows all users unrestricted access to files and folders 
(subject to any broader restrictions imposed by Windows or your network). You can 
control who has access to Cindex and (to some extent) where Cindex seeks and saves 
files.

Establishing an 
Administrator

To impose administrative restrictions on Cindex users, you must become an administra-
tor. To do this, choose Preferences from the Edit menu, then click the Administrator tab 
(Figure 2).

FIGURE 2. Administrator Preferences

Under Password enter (once in each text box) the password you will use to control subse-
quent access to the Administrator tab. The two entries must match before Cindex will 
accept them.
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The password may contain up to 31 characters, or it may be empty. If you set no pass-
word, any user will have access to the Administrator tab.

NOTE: If you use a password you should make a note of it. If you forget your password 
you will have no access to administrative settings

After an administrator password has been established, whenever you subsequently begin 
a session with Cindex it will prompt you for a user identifier and password. Password val-
idation is case-sensitive.

User Authentication The standard edition of Cindex allows an indexer to supply an (optional) user identifier 
that Cindex attaches to a record whenever that record is added or edited. The Publishers’ 
Edition allows the administrator to require a user to provide an identifier, and can 
authenticate this identifier against a list kept in a file. Settings that control user authenti-
cation are in the User ID box on the Administrator tab (Figure 2).

Check Required to make Cindex require a user ID before allowing access.

Check Validate to make Cindex check that the user ID is valid. If this is checked Cindex 
validates the ID against a list kept in a validation file. User ID validation is case-insensi-
tive. Click ID File… to specify the path to the file that contains the list of authorized 
users. If Validate is unchecked, Cindex will accept any identifier the user enters.

If Validate is checked and no validation file is specified (or the specified file does not 
exist), Cindex accepts identifiers without checking their authenticity.

Validation File The validation file can reside anywhere on your network. Cindex requires read access to 
the file. The file may have any name but must have the filename extension .usr. Each 
entry in the file must be on a single line terminated by a carriage-return, line-feed combi-
nation. The entry must begin with (up to four) characters that identify the user. Cindex 
disregards letter case when checking letters in an identifier.

An ID terminated by a semicolon can be followed optionally be a comment. The follow-
ing entries in the validation file are therefore both acceptable:

DXML
DXML;   David Light
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Logon When Cindex is configured to require a user identifier or if you have set up an adminis-
trative password, it displays a dialog box when it starts (Figure 3).

FIGURE 3. Cindex Logon

A user must provide an identifier before Cindex will permit access. If validation has been 
enabled, access will be allowed only if the identifier matches an entry in the validation 
file.

A password is required only for administrative access. If you provide a password that 
matches one previously entered, Cindex will display the Administrator tab when you 
choose Preferences from the Edit menu; if your password does not match, the Administra-
tor tab is not displayed.

The password and user ID are not linked: Cindex does not check that the user ID and 
password belong to each other.

Multiple Sessions Cindex is normally configured so that only one instance can be active at any one time on 
a single computer. The administrator can specify whether or not multiple instances of 
Cindex can run concurrently on a single computer. To enable multiple instances, check 
Allow Multiple Sessions.

File Placement
The administrator can specify what rights other users have to change folders via the Fold-
ers tab in Preferences (Figure 1).

Depending on the file type, the administrator can specify:

• Whether or not a user is taken to a default folder for Open/Save operations.
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• Whether or not the user can move out of the folder initially opened by the Save As… 
dialog box.

• Whether or not the user can specify a default folder.

To inspect or change access settings, choose Preferences (Edit menu) then click the Admin-
istrator tab (Figure 2). Under Files there is a tab for each file type for which settings can be 
made. Not all options are available for all file types.

Taking the User to a 
Default Folder

When Cindex displays a file dialog box (New… Open… Save As…) it can take the user to 
the specified folder for the file type (specified via the Folders tab), or it can take the user 
to the last folder used for a file operation.

To make Cindex take the user to the specified folder, check Take User to Default Folder on 
Open/Save. To make Cindex take the user to the last-used folder, uncheck Take User to 
Default Folder on Open/Save.

NOTE: When you open a file via Open…, Cindex will always take you to the default 
folder for indexes. If you choose (from the drop-down list in the Open dialog box) a style 
sheet or abbreviation set, Cindex does not change the folder. When you save style sheet 
or set of abbreviations, Cindex will take you to the default folder for that file type (if 
Move to Default Folder on Open/Save is checked).

You cannot set Take User to Default Folder on Open/Save for tag sets and user dictionar-
ies. Cindex always uses the default folder when working with these kinds of files.

Moving Through Folders When Cindex saves files of the specified type, and presents the user with the Save As… 
dialog box, the user can normally change the folder before saving the file. You can set 
Cindex so that if the user is taken to a default folder (specified through the Folders tab in 
Preferences), the user must use that folder when saving files of the specified type.

To prevent users changing the folder in which the file will be saved, uncheck User Can 
Change Folder on Save.

To permit users to change the folder in which the file will be saved, check User Can Change 
Folder on Save.

NOTE: You can make this setting only if Take User to Default Folder on Open/Save is 
checked. If Take User to Default Folder on Open/Save is unchecked, or no default folder has 
been specified, User Can Change Folder on Save is always checked.
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User Control of Default 
Folders

The administrator can specify whether or not users can change (via the Folders tab under 
Preferences) the default folders for files of specified types. The administrator always has 
unrestricted rights to change default folders.

To permit a user to change the default folder, check User Can Set Default Folder. 

To prevent a user changing the default folder, uncheck User Can Set Default Folder. When 
this is unchecked the corresponding Set… button on the Folders tab is dimmed.

Access to Indexes
The administrator can control whether or not a user can create and modify indexes, and 
whether or not a user can have read-only access to an index that has already been opened 
by someone else.

Write Access to Indexes To permit a user freely to make and modify indexes, check Allow Write Access to Indexes. 
To prevent a user creating or modifying indexes (while permitting read-only access to 
existing indexes) uncheck Allow Write Access to Indexes. This item is checked when Cindex 
is first installed.

Shared Access to Open 
Indexes

To allow a user read-only access to an index that is already open, check Allow Read-Only 
Access to Open Indexes. When this is checked, users have access as described in “Sharing 
Indexes” on page 5. When this is unchecked, a user attempting to open an already open 
index will be warned and denied access. This item is checked when Cindex is first 
installed.


